¡Bienvenido!

Esta comunidad es para profesionales y entusiastas de nuestros productos y servicios, compartir los mejores contenidos y nuevas ideas de marketing, construir su perfil profesional y mejorar el mercado para todos.

0

Imposible instalar el módulo "l10n_cl_fe" porqué hay una dependencia externa no resuelta: No module named facturacion_electronica

por
Juan Pablo Lorca
en 09-06-20 17:05 391 vistas

Hola instalando el addon me indica que no existe el módulo sin embargo ya está instalado, ver:


$ sudo pip3 install facturacion_electronica

Requirement already satisfied: facturacion_electronica in /root/.local/lib/python3.7/site-packages (0.11.21)

Requirement already satisfied: pytz in /root/.local/lib/python3.7/site-packages (from facturacion_electronica) (2020.1)

Requirement already satisfied: cryptography>=2.9.1 in /root/.local/lib/python3.7/site-packages (from facturacion_electronica) (2.9.2)

Requirement already satisfied: pdf417gen>=0.6.0 in /root/.local/lib/python3.7/site-packages (from facturacion_electronica) (0.7.1)

Requirement already satisfied: pyOpenSSL in /usr/lib/python3/dist-packages (from facturacion_electronica) (19.0.0)

Requirement already satisfied: requests==2.21.0 in /usr/lib/python3/dist-packages (from facturacion_electronica) (2.21.0)

Requirement already satisfied: urllib3==1.24.3 in /root/.local/lib/python3.7/site-packages (from facturacion_electronica) (1.24.3)

Requirement already satisfied: lxml in /root/.local/lib/python3.7/site-packages (from facturacion_electronica) (4.5.1)

Requirement already satisfied: suds-jurko in /root/.local/lib/python3.7/site-packages (from facturacion_electronica) (0.6)

Requirement already satisfied: certifi in /usr/lib/python3/dist-packages (from facturacion_electronica) (2018.8.24)

Requirement already satisfied: six>=1.4.1 in /usr/lib/python3/dist-packages (from cryptography>=2.9.1->facturacion_electronica) (1.12.0)

Requirement already satisfied: cffi!=1.11.3,>=1.8 in /root/.local/lib/python3.7/site-packages (from cryptography>=2.9.1->facturacion_electronica) (1.14.0)

Requirement already satisfied: Pillow>=2.0.0 in /root/.local/lib/python3.7/site-packages (from pdf417gen>=0.6.0->facturacion_electronica) (7.1.2)

Requirement already satisfied: future in /root/.local/lib/python3.7/site-packages (from pdf417gen>=0.6.0->facturacion_electronica) (0.18.2)

Requirement already satisfied: pycparser in /root/.local/lib/python3.7/site-packages (from cffi!=1.11.3,>=1.8->cryptography>=2.9.1->facturacion_electronica) (2.20)

1.- recordar que deben reiniciar el servicio odoo

2.- depende del usuario o el entorno, puede que este encapsulado por virtualemv o por docker u otro sistema , por lo que deben instalarlo en su respectivo entorno

Daniel Alejandro Santibanez Polanco, Daniel Santibáñez Polanco
de 09-06-20 17:36

3.- tambien fijarse si esta instaldo a nivel local o global, y que el usuario que ejucta odo tiene acceso

Daniel Alejandro Santibanez Polanco, Daniel Santibáñez Polanco
de 09-06-20 17:37

Mantener informado

Acerca de esta comunidad

Esta comunidad Relacionada a Odoo y la Facturación electrónica Chilena.
Cualquier consulta pública sobre los módulos abiertos se puede hacer aquí
Lea los lineamientos

Herramientas de las preguntas

12 seguidor(es)

Estadísticas

Preguntado: 09-06-20 17:05
Visto: 391 veces
Última actualización: 09-06-20 17:33